Pre Install
1. Проверить наличие установленных пакетов:
system SUNWarc Lint Libraries (usr)
system SUNWbtool CCS tools bundled with SunOS
system SUNWhea SunOS Header Files
system SUNWi15cs X11 ISO8859-15 Codeset Support
system SUNWi1cs X11 ISO8859-1 Codeset Support
system SUNWi1of ISO-8859-1 (Latin-1) Optional Fonts
system SUNWlibC Sun Workshop Compilers Bundled libC
system SUNWlibms Math & Microtasking Libraries (Usr)
system SUNWsprot Solaris Bundled tools
system SUNWtoo Programming Tools
system SUNWxwfnt X Window System platform required fonts
Для проверки выполнить команду:
#su -
#pkginfo -i SUNWarc SUNWbtool SUNWhea SUNWlibC SUNWlibms SUNWsprot SUNWtoo SUNWi1of SUNWi1cs SUNWi15cs SUNWxwfnt
Устанавливать недостающие пакеты так:
# pkgadd -d . SUNWsprot
2. Проверить наличие установленных патчей ОС:
120753-06: SunOS 5.10: Microtasking libraries (libmtsk) patch
139574-03: SunOS 5.10
141414-02
141444-09
119963-14: SunOS 5.10: Shared library patch for C++
124861-15: SunOS 5.10 Compiler Common patch for Sun C C++ (optional)
125555-03
139555-08
140796-01
140899-01
141016-01
141414-10
141736-05
Для проверки выполнить команды:
#showrev -p |grep 120753
#showrev -p |grep 139574
#showrev -p |grep 141414
#showrev -p |grep 141444
#showrev -p |grep 119963
#showrev -p |grep 124861
#showrev -p |grep 125555
#showrev -p |grep 139555
#showrev -p |grep 140796
#showrev -p |grep 140899
#showrev -p |grep 141016
#showrev -p |grep 141414
#showrev -p |grep 141736
или так:
#patchadd -p | grep 141736
Устанавливать недостающие патчи так:
#patchadd /patch-dir/patch-ID-revision
#patchadd /patch-dir/139555-08
3. Настройка параметров TCP/IP стека:
#vi /etc/init.d/ndd.ora
ndd -set /dev/tcp tcp_smallest_anon_port 9000
ndd -set /dev/tcp tcp_largest_anon_port 65500
ndd -set /dev/udp udp_smallest_anon_port 9000
ndd -set /dev/udp udp_largest_anon_port 65500
ndd -set /dev/udp udp_xmit_hiwat 65536
ndd -set /dev/udp udp_recv_hiwat 65536
#chmod 744 /etc/init.d/ndd.ora
#chown root:sys /etc/init.d/ndd.ora
#ln /etc/init.d/ndd.ora /etc/rc2.d/S99ndd.ora
4. Создание групп и пользователей:
#groupadd -g 1000 oinstall
#groupadd -g 1200 dba
#groupadd -g 1201 oper
#groupadd -g 1100 asmadmin
#groupadd -g 1300 asmdba
#groupadd -g 1301 asmoper
#useradd -u 1100 -g oinstall -G asmadmin,asmdba,dba,asmoper -m -d /export/home/oragrid -s /bin/bash oragrid
#useradd -u 1101 -g oinstall -G dba,oper,asmdba -m -d /export/home/oradb -s /bin/bash oradb
#passwd oragrid
#passwd oradb
#passwd oracle
6. Создание проекта и настройка параметров ядра ОС:
#projects -l
#projdel group.dba
#projadd group.dba
#usermod -K project=group.dba oradb
#usermod -K project=group.dba oragrid
#projmod -sK "project.max-shm-memory=(priv,70gb,deny)" group.dba
(Bug 15792293: projmod -sK "process.max-stack-size=(privileged,9223372036854775807,deny)" group.dba)
#projmod -sK "process.max-stack-size=(privileged,33554432,deny)" group.dba
#projmod -sK "process.max-file-descriptor=(privileged,65536,deny)" group.dba
#projmod -sK "process.max-sem-nsems=(priv,1024,deny)" group.dba
#projmod -sK "project.max-sem-ids=(priv,512,deny)" group.dba
#projmod -sK "project.max-shm-ids=(priv,512,deny)" group.dba
#vi /etc/system
set noexec_user_stack=1
7. Создание директорий для установки Oracle Restart Software:
#mkdir -p /u01/app/oraInventory
#chown -R oragrid:oinstall /u01/app/oraInventory
#chmod -R 775 /u01/app/oraInventory
#mkdir -p /u01/app/11.2.0.3
#chown -R oragrid:oinstall /u01/app/11.2.0.3
#chmod -R 775 /u01/app/11.2.0.3
#mkdir -p /u01/app/oragrid
#chown -R oragrid:oinstall /u01/app/oragrid
#chmod -R 775 /u01/app/oragrid
#mkdir -p /u01/app/oradb
#chown -R oradb:oinstall /u01/app/oradb
#chmod -R 775 /u01/app/oradb
8. Подготовка дисковых устройств для работы с ASM
Для ASM используются сырые устройства (raw devices).
Каждый из дисков размечается следующим образом:
Part.. Tag....... Flag... Cylinders ..Size ......Blocks
0... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
1... unassigned ...wu ...0 ...........0 ........(0/0/0).....0
2... backup .......wu ...0 - 65532 ...463.98GB .(65533/0/0) 973033984
3... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
4... unassigned ...wm ...3 - 65532 ...463.96GB .(65530/0/0) 972989440
5... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
6... unassigned ...wm ...0 ...........0 ........(0/0/0).... 0
7... unassigned ...wm ...0 ...........0 ........(0/0/0).... 0
Установить следующие атрибуты дисков:
#chown oragrid:asmadmin /dev/rdsk/c0t60080E50002C0A60000004E651108D32d0s4
#chmod 660 /dev/rdsk/c0t60080E50002C0A60000004E651108D32d0s4
#ls -lhL /dev/rdsk/ |grep oragrid
crw-rw---- 1 oragrid asmadmin 118, 268 Nov 8 14:59 c6t600A0B8000263CE200008EDD5003C2BCd0s4
9. Install Grid Infrastructure for standalone server
export DISPLAY=XX.XX.XX.XX:0.0
su - oragrid
$ cd grid
$./runInstaller
Oracle Base: /u01/app/oragrid
Software Location: /u01/app/11.2.0.3/grid
$su -
#/u01/app/oraInventory/orainstRoot.sh
#/u01/app/11.2.0.3/grid/root.sh
10. Install Database Software
#su - oradb
$ cd database
$./runInstaller
Oracle base: /u01/app/oradb
Software Location: /u01/app/oradb/product/11.2.0.3/dbhome_1
$su -
#/u01/app/oradb/product/11.2.0.3/dbhome_1/root.sh
11. Post Install (for role separate)
# chmod 775 /u01/app/oradb/product/11.2.0.3/dbhome_1/dbs
# chmod 775 /u01/app/oradb/product/11.2.0.3/dbhome_1/srvm/admin
# su - oragrid
$cd /u01/app/11.2.0.3/grid/bin
$./setasmgidwrap o=/u01/app/oradb/product/11.2.0.3/dbhome_1/bin/oracle
.......
$./setasmgidwrap o=ORACLE_HOME2
$./setasmgidwrap o=ORACLE_HOME2
12. Создаем profiles:
#su - oradb
$cd ~
$vi .bash_profile
umask 027
export EDITOR=vi
export TMP=/tmp
export TMPDIR=/tmp
export PATH=/usr/bin:/usr/sbin
export ORACLE_HOSTNAME=myserver.sun.com
export ORACLE_BASE=/u01/app/oradb
export ORACLE_HOME=${ORACLE_BASE}/product/11.2.0.3/dbhome_1
export PATH=${ORACLE_HOME}/OPatch:${ORACLE_HOME}/bin:${PATH}
export PS1='${ORACLE_SID}:\h:\w\$'
su - oragrid
$cd ~
$vi .bash_profile
umask 022
export EDITOR=vi
export TMP=/tmp
export TMPDIR=/tmp
export PATH=/usr/bin:/usr/sbin
export LD_LIBRARY_PATH_64=/u01/app/oradb/product/11.2.0.3/dbhome_1/jdk/jre/lib/sparcv9/server:/u01/app/oradb/product/11.2.0.3/dbhome_1/lib
export ORACLE_SID=+ASM
export ORACLE_HOME=/u01/app/11.2.0.3/grid
export PATH=${ORACLE_HOME}/OPatch:${ORACLE_HOME}/bin:$PATH
export PS1='${ORACLE_SID}:\h:\w\$'
Ставим PSU 11.2.0.3.4
Patch 14275572 - 11.2.0.3.4 GI Patch Set Update (Includes Database PSU 11.2.0.3.4)
Устанавливать так:
1. Stop the CRS managed resources running from DB homes.
# su - oraagent
$ emctl stop agent
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl stop home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Oracle ACFS file systems на которой расположен ORACLE_HOME размонтировать.
2. Run the pre root script.
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -unlock
3. Unzipping
# su - oragrid
$cd /tmp
$unzip p14275572_112030_SOLARIS64.zip
$ls -l
total 552336
drwxrwxr-x 4 oragrid oinstall 307 Jul 18 09:21 14275572
drwxr-xr-x 5 oragrid oinstall 302 Jul 18 09:21 14275605
4. Apply the CRS patch using.
$ /u01/app/11.2.0.3/grid/OPatch/opatch napply -oh /u01/app/11.2.0.3/grid -local /tmp/14275572
$ /u01/app/11.2.0.3/grid/OPatch/opatch apply -oh /u01/app/11.2.0.3/grid -local /tmp/14275605
5. Run the pre script for DB component of the patch.
# su - oradb
$ /tmp/14275572/custom/server/14275572/custom/scripts/prepatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
6. Apply the DB patch.
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch napply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14275572/custom/server/14275572
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch apply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14275605
7. Run the post script for DB component of the patch.
$ /tmp/14275572/custom/server/14275572/custom/scripts/postpatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
8. Run the post script.
$su -
Run the post script.
# /u01/app/11.2.0.3/grid/rdbms/install/rootadd_rdbms.sh
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -patch
9. Start the CRS managed resources that were earlier running from DB homes.
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl start home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Проверяем:
$/u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch lsinventory
$/u01/app/11.2.0.3/grid/OPatch/opatch lsinventory
Ставим PSU 11.2.0.3.5
Patch 14727347 - 11.2.0.3.5 GI Patch Set Update (Includes Database PSU 11.2.0.3.5)
Устанавливать так:
1. Stop the CRS managed resources running from DB homes.
# su - oraagent
$ emctl stop agent
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl stop home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Oracle ACFS file systems на которой расположен ORACLE_HOME размонтировать.
2. Run the pre root script.
$su -
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -unlock
3. Unzipping
# su - oragrid
$cd /tmp
$unzip p14727347_112030_SOLARIS64.zip
$ls -l
total 552336
drwxrwxr-x 4 oragrid oinstall 307 Jul 18 09:21 15876003
drwxr-xr-x 5 oragrid oinstall 302 Jul 18 09:21 14727310
4. Apply the CRS patch using.
$ /u01/app/11.2.0.3/grid/OPatch/opatch napply -oh /u01/app/11.2.0.3/grid -local /tmp/15876003
$ /u01/app/11.2.0.3/grid/OPatch/opatch apply -oh /u01/app/11.2.0.3/grid -local /tmp/14727310
5. Run the pre script for DB component of the patch.
# su - oradb
$ /tmp/15876003/custom/server/15876003/custom/scripts/prepatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
6. Apply the DB patch.
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch napply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/15876003/custom/server/15876003
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch apply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14727310
7. Run the post script for DB component of the patch.
$ /tmp/15876003/custom/server/15876003/custom/scripts/postpatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
8. Run the post script.
$su -
Run the post script.
# /u01/app/11.2.0.3/grid/rdbms/install/rootadd_rdbms.sh
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -patch
9. Start the CRS managed resources that were earlier running from DB homes.
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl start home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Проверяем:
$/u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch lsinventory
$su - oragrid
$/u01/app/11.2.0.3/grid/OPatch/opatch lsinventory
Во время установки PSU будут появляться следующие сообщения:
OPatch found the word "warning" in the stderr of the make command.
Please look at this stderr. You can re-run this make command.
Stderr output:
ld: warning: output object option (-o, --output) appears more than once, first setting taken
ld: warning: symbol '_init' not found, but .init section exists - possible link-edit without using the compiler driver
ld: warning: symbol '_fini' not found, but .fini section exists - possible link-edit without using the compiler driver
OPatch found the word "warning" in the stderr of the make command.
Please look at this stderr. You can re-run this make command.
Stderr output:
ld: warning: symbol '_start' has differing types:
(file /u01/app/11.2.0.3/grid/lib/prod/lib/v9/crt1.o type=FUNC; file /u01/app/11.2.0.3/grid/lib//libserver11.a(skds.o) type=OBJT );
Bug 15975368 : WARNING: SYMBOL `_INIT' AND _FINI WHILE INSTALL GRID INFRASTRUCTURE PATCH SET UP
WORKAROUND:
-----------
Need to confirm from development , Does this warning message can be ignore.
Bug 13912649 : LD: WARNING: SYMBOL '_START' WHILE INSTALLING 11.2.0.3
Click to add to Favorites Email link to this document Printable Page To BottomTo Bottom
- There are no other errors/failures around "ld: warning"
- Oracle componnt relink is successfull even with "ld: warning" message
All "ld: warning" messages can be safely ignored if there are no other
FATAL/SEVER errors.
Для db_home существует патч (11.2.0.2 и 11.2.0.3) :
Patch 13920888: LD: WARNING: SYMBOL '_START' WHILE INSTALLING 11.2.0.2 ON SOLARIS PLATFORM
p13920888_11203_SOLARIS64.zip
(4) Bugs Fixed by This Patch
---------------------------------
The following are the bugs fixed by this patch:
13920888:LD WARNING SYMBOL '_START' WHILE INSTALLING 11.2.0.2 ON SOLARIS PLATFORM
1. Проверить наличие установленных пакетов:
system SUNWarc Lint Libraries (usr)
system SUNWbtool CCS tools bundled with SunOS
system SUNWhea SunOS Header Files
system SUNWi15cs X11 ISO8859-15 Codeset Support
system SUNWi1cs X11 ISO8859-1 Codeset Support
system SUNWi1of ISO-8859-1 (Latin-1) Optional Fonts
system SUNWlibC Sun Workshop Compilers Bundled libC
system SUNWlibms Math & Microtasking Libraries (Usr)
system SUNWsprot Solaris Bundled tools
system SUNWtoo Programming Tools
system SUNWxwfnt X Window System platform required fonts
Для проверки выполнить команду:
#su -
#pkginfo -i SUNWarc SUNWbtool SUNWhea SUNWlibC SUNWlibms SUNWsprot SUNWtoo SUNWi1of SUNWi1cs SUNWi15cs SUNWxwfnt
Устанавливать недостающие пакеты так:
# pkgadd -d . SUNWsprot
2. Проверить наличие установленных патчей ОС:
120753-06: SunOS 5.10: Microtasking libraries (libmtsk) patch
139574-03: SunOS 5.10
141414-02
141444-09
119963-14: SunOS 5.10: Shared library patch for C++
124861-15: SunOS 5.10 Compiler Common patch for Sun C C++ (optional)
125555-03
139555-08
140796-01
140899-01
141016-01
141414-10
141736-05
Для проверки выполнить команды:
#showrev -p |grep 120753
#showrev -p |grep 139574
#showrev -p |grep 141414
#showrev -p |grep 141444
#showrev -p |grep 119963
#showrev -p |grep 124861
#showrev -p |grep 125555
#showrev -p |grep 139555
#showrev -p |grep 140796
#showrev -p |grep 140899
#showrev -p |grep 141016
#showrev -p |grep 141414
#showrev -p |grep 141736
или так:
#patchadd -p | grep 141736
Устанавливать недостающие патчи так:
#patchadd /patch-dir/patch-ID-revision
#patchadd /patch-dir/139555-08
3. Настройка параметров TCP/IP стека:
#vi /etc/init.d/ndd.ora
ndd -set /dev/tcp tcp_smallest_anon_port 9000
ndd -set /dev/tcp tcp_largest_anon_port 65500
ndd -set /dev/udp udp_smallest_anon_port 9000
ndd -set /dev/udp udp_largest_anon_port 65500
ndd -set /dev/udp udp_xmit_hiwat 65536
ndd -set /dev/udp udp_recv_hiwat 65536
#chmod 744 /etc/init.d/ndd.ora
#chown root:sys /etc/init.d/ndd.ora
#ln /etc/init.d/ndd.ora /etc/rc2.d/S99ndd.ora
4. Создание групп и пользователей:
#groupadd -g 1000 oinstall
#groupadd -g 1200 dba
#groupadd -g 1201 oper
#groupadd -g 1100 asmadmin
#groupadd -g 1300 asmdba
#groupadd -g 1301 asmoper
#useradd -u 1100 -g oinstall -G asmadmin,asmdba,dba,asmoper -m -d /export/home/oragrid -s /bin/bash oragrid
#useradd -u 1101 -g oinstall -G dba,oper,asmdba -m -d /export/home/oradb -s /bin/bash oradb
#passwd oragrid
#passwd oradb
#passwd oracle
6. Создание проекта и настройка параметров ядра ОС:
#projects -l
#projdel group.dba
#projadd group.dba
#usermod -K project=group.dba oradb
#usermod -K project=group.dba oragrid
#projmod -sK "project.max-shm-memory=(priv,70gb,deny)" group.dba
(Bug 15792293: projmod -sK "process.max-stack-size=(privileged,9223372036854775807,deny)" group.dba)
#projmod -sK "process.max-stack-size=(privileged,33554432,deny)" group.dba
#projmod -sK "process.max-file-descriptor=(privileged,65536,deny)" group.dba
#projmod -sK "process.max-sem-nsems=(priv,1024,deny)" group.dba
#projmod -sK "project.max-sem-ids=(priv,512,deny)" group.dba
#projmod -sK "project.max-shm-ids=(priv,512,deny)" group.dba
#vi /etc/system
set noexec_user_stack=1
7. Создание директорий для установки Oracle Restart Software:
#mkdir -p /u01/app/oraInventory
#chown -R oragrid:oinstall /u01/app/oraInventory
#chmod -R 775 /u01/app/oraInventory
#mkdir -p /u01/app/11.2.0.3
#chown -R oragrid:oinstall /u01/app/11.2.0.3
#chmod -R 775 /u01/app/11.2.0.3
#mkdir -p /u01/app/oragrid
#chown -R oragrid:oinstall /u01/app/oragrid
#chmod -R 775 /u01/app/oragrid
#mkdir -p /u01/app/oradb
#chown -R oradb:oinstall /u01/app/oradb
#chmod -R 775 /u01/app/oradb
8. Подготовка дисковых устройств для работы с ASM
Для ASM используются сырые устройства (raw devices).
Каждый из дисков размечается следующим образом:
Part.. Tag....... Flag... Cylinders ..Size ......Blocks
0... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
1... unassigned ...wu ...0 ...........0 ........(0/0/0).....0
2... backup .......wu ...0 - 65532 ...463.98GB .(65533/0/0) 973033984
3... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
4... unassigned ...wm ...3 - 65532 ...463.96GB .(65530/0/0) 972989440
5... unassigned ...wm ...0 ...........0 ........(0/0/0).....0
6... unassigned ...wm ...0 ...........0 ........(0/0/0).... 0
7... unassigned ...wm ...0 ...........0 ........(0/0/0).... 0
Установить следующие атрибуты дисков:
#chown oragrid:asmadmin /dev/rdsk/c0t60080E50002C0A60000004E651108D32d0s4
#chmod 660 /dev/rdsk/c0t60080E50002C0A60000004E651108D32d0s4
#ls -lhL /dev/rdsk/ |grep oragrid
crw-rw---- 1 oragrid asmadmin 118, 268 Nov 8 14:59 c6t600A0B8000263CE200008EDD5003C2BCd0s4
Table 1 Installation Types and Associated Zip Files
Installation Type | Zip File |
---|---|
Oracle Database (includes Oracle Database and Oracle RAC) Note: you must download both zip files to install Oracle Database. |
p10404530_112030_ platform _1of7.zip p10404530_112030_ platform _2of7.zip |
Oracle Grid Infrastructure (includes Oracle ASM, Oracle Clusterware, and Oracle Restart) |
p10404530_112030_ platform _3of7.zip |
Oracle Database Client |
p10404530_112030_ platform _4of7.zip |
Oracle Gateways |
p10404530_112030_ platform _5of7.zip |
Oracle Examples |
p10404530_112030_ platform _6of7.zip |
Deinstall |
p10404530_112030_ platform _7of7.zip |
9. Install Grid Infrastructure for standalone server
export DISPLAY=XX.XX.XX.XX:0.0
su - oragrid
$ cd grid
$./runInstaller
Oracle Base: /u01/app/oragrid
Software Location: /u01/app/11.2.0.3/grid
$su -
#/u01/app/oraInventory/orainstRoot.sh
#/u01/app/11.2.0.3/grid/root.sh
10. Install Database Software
#su - oradb
$ cd database
$./runInstaller
Oracle base: /u01/app/oradb
Software Location: /u01/app/oradb/product/11.2.0.3/dbhome_1
$su -
#/u01/app/oradb/product/11.2.0.3/dbhome_1/root.sh
11. Post Install (for role separate)
# chmod 775 /u01/app/oradb/product/11.2.0.3/dbhome_1/dbs
# chmod 775 /u01/app/oradb/product/11.2.0.3/dbhome_1/srvm/admin
# su - oragrid
$cd /u01/app/11.2.0.3/grid/bin
$./setasmgidwrap o=/u01/app/oradb/product/11.2.0.3/dbhome_1/bin/oracle
.......
$./setasmgidwrap o=ORACLE_HOME2
$./setasmgidwrap o=ORACLE_HOME2
12. Создаем profiles:
#su - oradb
$cd ~
$vi .bash_profile
umask 027
export EDITOR=vi
export TMP=/tmp
export TMPDIR=/tmp
export PATH=/usr/bin:/usr/sbin
export ORACLE_HOSTNAME=myserver.sun.com
export ORACLE_BASE=/u01/app/oradb
export ORACLE_HOME=${ORACLE_BASE}/product/11.2.0.3/dbhome_1
export PATH=${ORACLE_HOME}/OPatch:${ORACLE_HOME}/bin:${PATH}
export PS1='${ORACLE_SID}:\h:\w\$'
su - oragrid
$cd ~
$vi .bash_profile
umask 022
export EDITOR=vi
export TMP=/tmp
export TMPDIR=/tmp
export PATH=/usr/bin:/usr/sbin
export LD_LIBRARY_PATH_64=/u01/app/oradb/product/11.2.0.3/dbhome_1/jdk/jre/lib/sparcv9/server:/u01/app/oradb/product/11.2.0.3/dbhome_1/lib
export ORACLE_SID=+ASM
export ORACLE_HOME=/u01/app/11.2.0.3/grid
export PATH=${ORACLE_HOME}/OPatch:${ORACLE_HOME}/bin:$PATH
export PS1='${ORACLE_SID}:\h:\w\$'
Ставим PSU 11.2.0.3.4
Patch 14275572 - 11.2.0.3.4 GI Patch Set Update (Includes Database PSU 11.2.0.3.4)
Устанавливать так:
1. Stop the CRS managed resources running from DB homes.
# su - oraagent
$ emctl stop agent
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl stop home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Oracle ACFS file systems на которой расположен ORACLE_HOME размонтировать.
2. Run the pre root script.
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -unlock
3. Unzipping
# su - oragrid
$cd /tmp
$unzip p14275572_112030_SOLARIS64.zip
$ls -l
total 552336
drwxrwxr-x 4 oragrid oinstall 307 Jul 18 09:21 14275572
drwxr-xr-x 5 oragrid oinstall 302 Jul 18 09:21 14275605
4. Apply the CRS patch using.
$ /u01/app/11.2.0.3/grid/OPatch/opatch napply -oh /u01/app/11.2.0.3/grid -local /tmp/14275572
$ /u01/app/11.2.0.3/grid/OPatch/opatch apply -oh /u01/app/11.2.0.3/grid -local /tmp/14275605
5. Run the pre script for DB component of the patch.
# su - oradb
$ /tmp/14275572/custom/server/14275572/custom/scripts/prepatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
6. Apply the DB patch.
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch napply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14275572/custom/server/14275572
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch apply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14275605
7. Run the post script for DB component of the patch.
$ /tmp/14275572/custom/server/14275572/custom/scripts/postpatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
8. Run the post script.
$su -
Run the post script.
# /u01/app/11.2.0.3/grid/rdbms/install/rootadd_rdbms.sh
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -patch
9. Start the CRS managed resources that were earlier running from DB homes.
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl start home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Проверяем:
$/u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch lsinventory
$/u01/app/11.2.0.3/grid/OPatch/opatch lsinventory
Ставим PSU 11.2.0.3.5
Patch 14727347 - 11.2.0.3.5 GI Patch Set Update (Includes Database PSU 11.2.0.3.5)
Устанавливать так:
1. Stop the CRS managed resources running from DB homes.
# su - oraagent
$ emctl stop agent
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl stop home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Oracle ACFS file systems на которой расположен ORACLE_HOME размонтировать.
2. Run the pre root script.
$su -
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -unlock
3. Unzipping
# su - oragrid
$cd /tmp
$unzip p14727347_112030_SOLARIS64.zip
$ls -l
total 552336
drwxrwxr-x 4 oragrid oinstall 307 Jul 18 09:21 15876003
drwxr-xr-x 5 oragrid oinstall 302 Jul 18 09:21 14727310
4. Apply the CRS patch using.
$ /u01/app/11.2.0.3/grid/OPatch/opatch napply -oh /u01/app/11.2.0.3/grid -local /tmp/15876003
$ /u01/app/11.2.0.3/grid/OPatch/opatch apply -oh /u01/app/11.2.0.3/grid -local /tmp/14727310
5. Run the pre script for DB component of the patch.
# su - oradb
$ /tmp/15876003/custom/server/15876003/custom/scripts/prepatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
6. Apply the DB patch.
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch napply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/15876003/custom/server/15876003
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch apply -oh /u01/app/oradb/product/11.2.0.3/dbhome_1 -local /tmp/14727310
7. Run the post script for DB component of the patch.
$ /tmp/15876003/custom/server/15876003/custom/scripts/postpatch.sh -dbhome /u01/app/oradb/product/11.2.0.3/dbhome_1
8. Run the post script.
$su -
Run the post script.
# /u01/app/11.2.0.3/grid/rdbms/install/rootadd_rdbms.sh
# /u01/app/11.2.0.3/grid/crs/install/roothas.pl -patch
9. Start the CRS managed resources that were earlier running from DB homes.
# su - oradb
$ /u01/app/oradb/product/11.2.0.3/dbhome_1/bin/srvctl start home -o /u01/app/oradb/product/11.2.0.3/dbhome_1 -s /export/home/oradb/state_file.oradb
Проверяем:
$/u01/app/oradb/product/11.2.0.3/dbhome_1/OPatch/opatch lsinventory
$su - oragrid
$/u01/app/11.2.0.3/grid/OPatch/opatch lsinventory
Во время установки PSU будут появляться следующие сообщения:
OPatch found the word "warning" in the stderr of the make command.
Please look at this stderr. You can re-run this make command.
Stderr output:
ld: warning: output object option (-o, --output) appears more than once, first setting taken
ld: warning: symbol '_init' not found, but .init section exists - possible link-edit without using the compiler driver
ld: warning: symbol '_fini' not found, but .fini section exists - possible link-edit without using the compiler driver
OPatch found the word "warning" in the stderr of the make command.
Please look at this stderr. You can re-run this make command.
Stderr output:
ld: warning: symbol '_start' has differing types:
(file /u01/app/11.2.0.3/grid/lib/prod/lib/v9/crt1.o type=FUNC; file /u01/app/11.2.0.3/grid/lib//libserver11.a(skds.o) type=OBJT );
Bug 15975368 : WARNING: SYMBOL `_INIT' AND _FINI WHILE INSTALL GRID INFRASTRUCTURE PATCH SET UP
WORKAROUND:
-----------
Need to confirm from development , Does this warning message can be ignore.
Bug 13912649 : LD: WARNING: SYMBOL '_START' WHILE INSTALLING 11.2.0.3
Click to add to Favorites Email link to this document Printable Page To BottomTo Bottom
- There are no other errors/failures around "ld: warning"
- Oracle componnt relink is successfull even with "ld: warning" message
All "ld: warning" messages can be safely ignored if there are no other
FATAL/SEVER errors.
Для db_home существует патч (11.2.0.2 и 11.2.0.3) :
Patch 13920888: LD: WARNING: SYMBOL '_START' WHILE INSTALLING 11.2.0.2 ON SOLARIS PLATFORM
p13920888_11203_SOLARIS64.zip
(4) Bugs Fixed by This Patch
---------------------------------
The following are the bugs fixed by this patch:
13920888:LD WARNING SYMBOL '_START' WHILE INSTALLING 11.2.0.2 ON SOLARIS PLATFORM